Overview
Although your customer may have configured a department and location for an employee in Paylocity, you may not see this information in the Groups Common Model in Merge unless the data in Paylocity is configured correctly.
Cause
Paylocity's API does not provide department details when the effective date of an employee is before the hire date.
Solution
Ask your customer to update the effective date to the hire date or a later date in Paylocity
Trigger a re-sync of the linked account in your Merge dashboard (or simply wait for the next regular sync)